
Microsoft Excel: Beginner to Advanced 

Complete Course Notes &  

SECTION 1: Course Overview & Excel Marketplace 

1.1 What is Microsoft Excel? 

Microsoft Excel is a powerful spreadsheet program that allows users to store, organize, manipulate, and 
analyze information. It consists of columns (vertical) and rows (horizontal), and each intersection is called a 

cell — which holds one point of data. 

• Used by an estimated 750 million people worldwide 

• 81%+ of businesses use Excel for data tracking and analysis 

• Certified Excel skills can increase earnings potential by 12% 

• Core uses: data visualization, budgeting, invoicing, training logs, business reporting 

 

1.2 Excel Job Opportunities & Salaries 

Mastering Excel opens doors to high-demand, well-paying roles. Data Analyst is ranked in the top 10 most 

in-demand jobs on LinkedIn. 

• Entry-level Data Analyst (<1 year): ~$52,000/yr 

• 1–4 years’ experience: ~$56,000/yr 

• 5–9 years’ experience: ~$63,000/yr 

• Senior level: $66,000+ /yr 

 

Key job roles requiring Excel skills: 

• Data Analyst – Spot trends, make forecasts, interpret data sets 

• Financial Analyst – Analyze P&L, Wall Street, private equity 

• Business Analyst – Analyze company performance overall 

• Admin Assistant, Accountant, Bookkeeper, Project Manager 

  



SECTION 2: Getting Started with Excel 

2.1 Opening Excel & The Start Screen 

• Open via desktop shortcut (double-click) or Start Menu (search 'Excel') 

• Start Screen has 3 tabs: Home (recent files, templates), New (blank workbook, templates), Open 

(browse files) 

• To check your Excel version: File > Account > About Excel 

• Version matters — some features in newer Excel are not compatible with older versions 

 

2.2 The Excel Interface 

Every element visible on screen is part of the Excel Interface. Key sections: 

• Quick Access Toolbar — Top-left; holds AutoSave, Save, Undo, Redo. Customizable via dropdown, 

right-clicking ribbon items, or File > Options 

• Ribbon — Runs across the top; contains tabs (Home, Insert, etc.), command groups, and command 

buttons. Double-click a tab to minimize/restore it 

• Formula Bar — Between the ribbon and cells; where formulas are entered and edited 

• Name Box — Left of the Formula Bar; displays the active cell reference (e.g., A1, B3) 

• Status Bar — Bottom of screen; shows view options (Normal, Page Layout, Page Break), zoom 

level, and auto-calculations (Sum, Average, Count, Min, Max) for selected cells. Right-click to 

customize 

 

2.3 Workbook vs. Worksheet 

• Workbook = the Excel file (.xlsx) that contains one or more worksheets 

• Worksheet = an individual sheet (tab) within the workbook, made up of rows and columns 

• Total rows per worksheet: 1,048,576 (Ctrl+Down Arrow to navigate to bottom) 

• Total columns per worksheet: 16,384 (column XFD) 

• Result: Over 17 billion cells per single worksheet 

• No hard limit on worksheets per workbook — limited by computer memory. Keep below 255 for 

performance 

 

2.4 Saving Workbooks 

• First save: File > Save As — choose location, enter filename, select file type 

• Default file type: .xlsx (standard Excel workbook) 

• Other common types: .xlsm (macro-enabled), .xltx (template), .csv (comma-delimited), .pdf 

• Subsequent saves: File > Save, or Ctrl+S (Windows) / Cmd+S (Mac) 

• Save As creates a new copy; Save overwrites the existing file 

 

 

 

 

 



2.5 Customizing the Interface 

Quick Access Toolbar (3 ways to add commands): 

○ 1. Click the dropdown arrow at the end of the toolbar 

○ 2. Right-click any ribbon command > 'Add to Quick Access Toolbar' 

○ 3. File > Options > Quick Access Toolbar 

 

Customizing the Ribbon: 

○ File > Options > Customize Ribbon 

○ Add new Groups, Commands, or entire Tabs 

○ Rename, reorder, or remove custom items 

○ Right-click group/tab in the dialog and select Remove to delete 

  



SECTION 3: Entering & Formatting Data 

3.1 Types of Data in Excel 

• Text values — Left-aligned by default; used as labels (headers, row names, titles) 

• Numeric values — Right-aligned by default; used in calculations; decimals line up 

• Date values — Treated as numbers by Excel; right-aligned; must be entered in a recognized date 

format 

Important: Mixing text and numeric values in a formula will cause an error.  

 

3.2 Formatting Date Values 

• Excel internally stores dates as numbers (e.g., Jan 1 2020 = 43831) 

• Apply date formatting via: Home > Number Group > dropdown > More Number Formats > Date > 

Custom 

• Custom format example: mmm-yyyy displays as Jan-2020 

• Use the Fill Handle to copy date formatting across adjacent cells — Excel detects the pattern and 

increments months automatically 

 

3.3 The Fill Handle 

• Located at the bottom-right corner of a selected cell — appears as a small black cross 

• Drag to copy values, formulas, or formatting to adjacent cells 

• Excel picks up patterns: entering 1, 2 then dragging will continue 3, 4, 5...  

• Entering a single value and dragging just copies (no pattern detected) 

 

3.4 Formatting Numeric Values 

• Currency format — Dollar sign sits directly beside the value; negative shown as minus sign 

• Accounting format — Dollar sign aligns to the left edge of the cell; negatives shown in parentheses 

• Comma Style — Like accounting but removes the dollar sign; good for interior rows 

• Percentage — Multiply decimal by 100 and add % 

• Increase/Decrease Decimal — Fine-tune precision of displayed values 

Tip: Pound signs (###) in a cell mean the column is too narrow to display the numeric value — widen the 

column. 

 

 

 

 

 

 

 

 

 



3.5 Cell Formatting — Font, Fill, Borders 

• Font Group (Home Tab): Bold (Ctrl+B), Italic, Underline, Font Size, Font Color 

• Fill Color (paint bucket icon): Change cell background color 

• Borders: Home > Font Group > Border dropdown — choose All Borders, Thick Outside, Bottom 

Border, etc. 

• Merge and Center: Select cells > Home > Alignment Group > Merge & Center — merges selected 

cells and centers the text 

• Merge Across: Merges multiple rows independently without centering 

 

3.6 Format Painter 

• Location: Home Tab > Clipboard Group 

• Copies ONLY the formatting (fill color, borders, font, number format) — not the content 

• Single click: applies format to one selection; Double-click: locks format painter on — click multiple 

areas then press Esc 

 

3.7 Cell Styles 

• Location: Home Tab > Styles Group 

• Saves a set of formatting options (fill, font, borders) as a reusable style 

• Modifying a style updates ALL cells that use that style across the entire workbook instantly  

• Uncheck Number Format when saving a style to avoid overwriting date/currency formats in styled 

cells 

 

3.8 Conditional Formatting 

• Location: Home Tab > Styles Group > Conditional Formatting 

• Automatically applies formatting to cells based on rules (values, formulas) 

• Built-in rules: Highlight Cells Rules (greater than, less than, equal to, duplicate values), Top/Bottom 

Rules, Data Bars, Color Scales, Icon Sets 

• Custom rule: Use a formula — IMPORTANT: use a relative cell reference (not absolute $G$4) so 

the rule applies correctly to each row 

• Manage Rules: Conditional Formatting > Manage Rules — to edit, delete, or reorder rules 

Example: Highlight percent-of-total values below 10% green, above 25% red. If using a formula rule, make 

the cell reference relative. 

  



SECTION 4: Managing Rows, Columns & Worksheets 

4.1 Adjusting Row Height & Column Width 

• Drag the boundary between row numbers or column letters to resize manually  

• Double-click the boundary to Auto-Fit (fits to widest/tallest content) 

• Home > Cells Group > Format > Row Height or Column Width for precise values 

• Select multiple rows/columns before dragging to resize them all uniformly 

 

4.2 Inserting & Deleting Rows/Columns 

• Home > Cells Group > Insert dropdown > Insert Sheet Rows / Insert Sheet Columns 

• Right-click a row/column header > Insert or Delete 

• Keyboard shortcuts: Ctrl++ (insert), Ctrl+- (delete) — with row/column selected 

• Shortcut: Shift+Spacebar selects the entire row of the active cell; Ctrl+Spacebar selects the entire 

column 

Note: All formulas update automatically when rows or columns are added or removed.  

 

4.3 Hiding & Unhiding Rows/Columns 

• Right-click column/row header > Hide 

• A double line between headers indicates hidden rows or columns 

• To unhide: select the headers on both sides > right-click > Unhide 

• Keyboard shortcut: Ctrl+0 (hide column), Ctrl+9 (hide row) 

• Unhide shortcuts: Ctrl+Shift+9 (row), Ctrl+Shift+0 (column) 

• To unhide ALL: Click the Select All arrow (top-left corner) > right-click any header > Unhide 

 

4.4 Moving, Copying & Pasting Data 

• Move: Hover over cell border until 4-arrow cursor appears, then drag 

• Cut (Ctrl+X) and Paste (Ctrl+V): removes from original, places at destination 

• Copy (Ctrl+C) and Paste (Ctrl+V): keeps original, creates a copy at destination 

• Marching ants (dashed border) indicate an active cut/copy — press Esc to cancel 

• Copy an entire worksheet: Select All (Ctrl+A) > Ctrl+C > go to new sheet > Ctrl+A > Ctrl+V 

 

4.5 Managing Worksheets 

• Rename: Double-click the sheet tab or right-click > Rename 

• Add new sheet: Click the + icon next to sheet tabs 

• Delete: Right-click tab > Delete — WARNING: cannot be undone 

• Move: Click and drag the sheet tab to the desired position 

• Copy: Right-click > Move or Copy > check 'Create a copy'; or Ctrl+drag the tab 

• Move/Copy to another workbook: Right-click > Move or Copy > select workbook from dropdown 

 

 



4.6 Cell & Workbook Protection 

Protecting individual cells: 

○ By default, all cells have the Locked property turned ON 

○ Protection has no effect until you enable it via: Review Tab > Protect Sheet 

○ To allow specific cells to be edited: select those cells > right-click > Format Cells > Protection Tab > 
uncheck Locked > then protect the sheet 

○ Optional password — if used, do not forget it; very difficult to recover 

 

Protecting workbook structure: 

○ Review Tab > Protect Workbook — prevents adding, deleting, moving, or renaming sheet tabs 

 

Password-protecting the file: 

○ File > Info > Protect Workbook > Encrypt with Password 

○ Users must enter password to open the file 

○ To remove: repeat same steps and clear the password field 

  



SECTION 5: Formulas & Functions 

5.1 Building Basic Formulas 

• All formulas MUST begin with the equal sign (=) 

• Can be typed directly in the cell or in the Formula Bar 

• Manual entry: =1000+500+750 — simple but inflexible 

• Cell referencing: =B4+B5+B6 — better; updates automatically if values change 

 

5.2 Order of Operations (PEMDAS) 

Excel follows standard mathematical order of operations — remembered by 'Please Excuse My Dear Aunt 

Sally': 

• P — Parentheses (calculated first) 

• E — Exponents 

• M/D — Multiplication and Division (left to right) 

• A/S — Addition and Subtraction (left to right) 

Use the Evaluate Formula tool (Formulas Tab) to step through how Excel calculates your formula.  

 

5.3 Relative vs. Absolute Cell References 

Relative References (e.g., B4): 

○ Change when a formula is copied — the reference shifts relative to its new position 

○ Copying a formula one column right: B4 becomes C4 

 

Absolute References (e.g., $E$9): 

○ Stay constant regardless of where the formula is copied 

○ Add dollar signs manually or press F4 to cycle through reference types 

○ Use when one part of a formula must always refer to the same fixed cell (e.g., a grand total) 

 

5.4 Core Functions 

SUM — Adds all numbers in a range: 

○ =SUM(B4:B8) 

○ AutoSum shortcut: Alt+= or Formulas Tab > AutoSum 

○ Watch out: AutoSum may guess the wrong range if total is placed to the right instead of below 

 

MIN / MAX — Returns smallest/largest value in a range: 

○ =MIN(B4:B8) | =MAX(B4:B8) 

○ Located under Formulas > More Functions > Statistical 

 

AVERAGE — Returns the mean of a range: 

○ =AVERAGE(B4:B8) 

 

 



COUNT / COUNTA / COUNTBLANK: 

○ COUNT — counts cells containing numbers only 

○ COUNTA — counts all non-empty cells (numbers + text) 

○ COUNTBLANK — counts empty cells in a range 

 

SUMIF — Sum values that meet a single condition: 

○ =SUMIF(range, criteria, sum_range) 

○ Example: =SUMIF(RegionCol, "North", SalesCol)  

 

SUMIFS — Sum values that meet multiple conditions: 

○ =SUMIFS(sum_range, criteria_range1, criteria1, criteria_range2, criteria2, ...) 

○ Limitation: Cannot sum across multiple OR conditions in one formula (need to add multiple SUMIFS) 

 

DSUM (Database Sum) — Like SUMIFS but uses a criteria table: 

○ =DSUM(database, field, criteria) 

○ Criteria table must have column headers that exactly match the database headers (use cell references to 
avoid typos) 

○ Advantage over SUMIFS: easily handles multiple OR-condition rows by adding additional rows to the 
criteria table 

 

SUBTOTAL — Performs calculations that IGNORE filtered rows: 

○ =SUBTOTAL(function_num, range) 

○ Function numbers: 9 = SUM, 1 = AVERAGE, 2 = COUNT, 3 = COUNTA, 4 = MAX, 5 = MIN 

○ Numbers 1-11 include manually hidden rows; 101-111 exclude them 

○ Unlike regular SUM, SUBTOTAL dynamically recalculates when filters are applied  

  



SECTION 6: Data Analysis — Sorting, Filtering & Tables 

6.1 Preparing a Dataset 

• A dataset (data set) is a contiguous range of cells with no blank rows 

• Row 1 should contain column headers (called headers or field names) 

• Blank rows within a dataset break sorting and filtering — Excel treats it as two separate lists 

• Test: Press Ctrl+A inside your data — if it selects only part, you have a break in your data 

 

6.2 Sorting Data 

• Single-column sort: Click any cell in the column > Data Tab > A-Z (ascending) or Z-A (descending) 

• Multi-level sort: Data Tab > Sort button — add levels, each with its own column and order 

• Excel can sort up to 64 levels 

• Custom sort: Sort dialog > Order dropdown > Custom List — use for chronological months (Jan, 

Feb, Mar) instead of alphabetical 

Important: Always sort the column you're grouping by BEFORE adding subtotals.  

 

6.3 Filtering Data 

• Enable filters: Data Tab > Filter button (adds dropdown arrows to all headers) 

• Click a dropdown to select/deselect specific values, or use predefined filters (Number Filters: Top 

10, Above Average, Between, etc.) 

• Active filter is indicated by a funnel icon on the column header dropdown 

• Multiple columns can be filtered simultaneously 

• Clear all filters: Data Tab > Clear 

• Filter by color: available after applying conditional formatting (filter by fill color or font color)  

 

6.4 Subtotals 

• Prerequisite: Sort the column you want subtotals for, then remove existing filters 

• Data Tab > Outline Group > Subtotal 

• Choose: At each change in [column], Use function [SUM/AVERAGE/COUNT etc.], Add subtotal to 

[column] 

• Creates automatic grouping levels — click Level 1 for grand total only, Level 2 for subtotals, Level 3 

for full detail 

• Click the +/- buttons beside rows to expand/collapse individual groups 

 

 

 

 

 

 

 

 



6.5 Excel Tables 

• Convert dataset to Table: Insert Tab > Table > confirm 'My table has headers'  

• Benefits: Auto-formatting with alternating row colors, built-in filter dropdowns, structured references 

in formulas 

• Total Row: Table Design Tab > check Total Row — auto-adds a summary row with dropdown to 

choose SUM, COUNT, AVERAGE, etc. 

• Adding data: Type in the row below the table — it automatically expands 

• Formulas in tables use column header names (e.g., [@Sales]) instead of cell references — makes 

formulas self-documenting 

• Table Styles: Table Design Tab > Table Styles group — apply or create custom styles 

 

6.6 Removing Duplicates 

• Data Tab > Data Tools Group > Remove Duplicates 

• Select which columns to check for duplicate values (use unique identifiers like Employee ID) 

• Excel KEEPS the first occurrence and removes subsequent duplicates — be aware of which record 

you want to keep 

• Better practice: Use Conditional Formatting > Highlight Cell Rules > Duplicate Values first to 

IDENTIFY duplicates, then sort/filter by color before deleting 

  



SECTION 7: Charts, Images & Visual Elements 

7.1 Inserting & Formatting Charts 

• Select data (including headers) > Insert Tab > Charts Group > choose chart type 

• Column/Bar charts: Best for comparing values across categories 

• Pie charts: Best for showing proportion of a whole — uses only ONE data series (one column of 

values) 

• Once inserted, chart and data are LINKED — changing source data automatically updates the chart 

 

Chart Design Tab options: 

○ Quick Layout — changes the arrangement of chart elements (title, legend, data labels) 

○ Change Colors — applies a different color scheme 

○ Chart Styles — changes background, effects, fonts 

○ Switch Row/Column — swaps what appears on the X-axis vs. in the Legend 

○ Select Data — add/remove data series or edit axis labels 

○ Change Chart Type — swap between column, bar, pie, etc. without losing formatting 

○ Move Chart — move to its own sheet or embed in a different sheet 

 

Format Tab options: 

○ Click any chart element (title, legend, bars, axis) to select it, then format using Shape Fill, Shape Outline, 
Shape Effects 

○ Add data labels via the + (Chart Elements) button 

○ To prevent a chart from printing: right-click chart > Format Chart Area > Properties > uncheck Print object 

 

7.2 Images, Shapes & Icons 

• Insert Tab > Illustrations Group > Pictures (from PC or online), Shapes, Icons (Office 365 only), 

SmartArt 

• Resize images: drag corner handles (diagonal arrow cursor) 

• Shape Format Tab: Shape Fill, Shape Outline, Shape Effects, Weight (line thickness) 

• Shape properties: right-click > Size and Properties — control Move/Size with cells or Don't move or 

size with cells 

• Icons (Office 365 only): More versatile than shapes — can be converted to individual shapes via 

'Convert to Shape' for component-level editing 

• Group objects: Select both > right-click > Group — they move together 

• SmartArt: Insert Tab > SmartArt — fancy visual representations (org charts, process flows, Venn 

diagrams, bulleted lists) 

 

 

 

 

 

 

 



7.3 Printing Options 

 

• File > Print (or Ctrl+P) opens the Print Preview and settings panel  

• Orientation: Portrait (tall) or Landscape (wide) 

• Scaling: Fit Sheet on One Page, Fit All Columns on One Page, etc. 

• Margins: Normal, Narrow, Wide, or Custom (can also center horizontally/vertically) 

• Print Area: Page Layout Tab > Print Area > Set Print Area — limits printing to selected cells only 

• Print Selection: File > Print > Settings dropdown > Print Selection — prints currently selected cells 

• Save as PDF: File > Print > select 'Microsoft Print to PDF' as printer, OR File > Save As > PDF file 

type 

• Page Layout View: View Tab > Page Layout — shows rulers, headers/footers, page boundaries; 

great for formatting before printing 

• Headers/Footers: Add page numbers, sheet name, date, file name in the top/bottom margin of each 

printed page 

  



SECTION 8: Advanced Features — Templates, Validation & 
Advanced Functions 

8.1 Excel Templates 

• Templates save all formatting, formulas, and page settings so you don't start from scratch each time 

• To create: Delete variable data (values that change each period), then File > Save As > change file 

type to Excel Template (.xltx) 

• Templates are saved in: Documents > Custom Office Templates 

• To use: Open Excel > New Tab > Personal Tab > select your template 

• Excel creates a copy (.xlsx) so the template file itself is never accidentally overwritten 

 

8.2 Data Validation 

Data Validation restricts what users can enter into cells — found at: Data Tab > Data Tools Group > 

Data Validation. 

 

Types of validation: 

○ Drop-down List: Source can be typed manually (comma-separated), selected from cells, or a named 
range 

○ Date: Restrict to a date range (e.g., between Jan 1, 2020 and Dec 31, 2021) 

○ Whole Number: Restrict to integers within a range (e.g., age >= 18) 

○ Text Length: Restrict by character count (e.g., ZIP code = exactly 5 digits) 

 

Customizing messages: 

○ Input Message Tab: Shows a helpful tooltip when the cell is selected 

○ Error Alert Tab: Customize the error message; choose Stop (blocks entry), Warning (allows override), or 
Information (just notifies) 

 

Dynamic drop-down lists: 

○ Convert the source data to a Table — the dropdown automatically includes new rows added to the table 

 

Dependent (cascading) dropdown lists using INDIRECT: 

○ Create named ranges matching category names (e.g., a range named 'Fruits', another named 
'Vegetables') 

○ In the food column's data validation source, enter: =INDIRECT(B3) — where B3 contains the category 
selection 

○ INDIRECT evaluates the TEXT in B3 as a cell reference or named range name, linking the two 
dropdowns 

  



SECTION 9: Key Shortcuts Reference 

 

Learning shortcuts is essential for Excel efficiency. Practice them consistently and they become second 

nature. 

 

Action Windows Mac 

Copy Ctrl+C Cmd+C 

Paste Ctrl+V Cmd+V 

Cut Ctrl+X Cmd+X 

Undo Ctrl+Z Cmd+Z 

Redo Ctrl+Y Cmd+Y 

Select All Ctrl+A Cmd+A 

Bold Ctrl+B Cmd+B 

Save Ctrl+S Cmd+S 

AutoSum Alt+= Cmd+Shift+T 

Insert Row/Column Ctrl++ Cmd++ 

Delete Row/Column Ctrl+- Cmd+- 

Go to last row Ctrl+Down Arrow Cmd+Down Arrow 

Select entire row Shift+Spacebar Shift+Spacebar 

Select entire column Ctrl+Spacebar Ctrl+Spacebar 

Absolute reference (F4) F4 Cmd+T 

Hide row Ctrl+9 Cmd+9 

Hide column Ctrl+0 Cmd+0 

 

— End of Course Notes — 


