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DaVinci Resolve 

Complete Video Editing Masterclass 

Comprehensive Course Note 

1. Introduction & Why DaVinci Resolve 

This masterclass covers everything from zero to producing high-quality, audience-retaining 

YouTube videos. The instructor emphasizes that knowledge without execution is useless — 

practice and repetition are essential. 

Why DaVinci Resolve? 

Cost Completely free — professional studios use it 

Current Version DaVinci Resolve 19 (updates released every 6–12 months) 

Compatibility Versions are visually very similar; skills transfer across updates 

Platform Windows, macOS, Linux 

 

Course Coverage 

• Copyright-free clips, sound effects, and music 

• Choosing and installing the right editing software 

• Using AI tools (Opus Clip) to speed up workflows  

• Live editing walkthrough of a real YouTube video from start to finish  

 

2. Installing DaVinci Resolve 

Go to blackmagicdesign.com, scroll to the free download section, fill in the registration form, and 

download. On Windows, extract the ZIP file and run the installer using default settings.  

Installation Steps 

• Search for 'DaVinci Resolve' and click the Blackmagic Design link 

• Click 'Free Download' and select the version for your OS 

• Complete the registration form and click 'Register and Download' 

• Extract the ZIP and double-click the installer 

• Leave all settings on default → Next → Accept License → Install → Finish  
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• Launch DaVinci Resolve and click 'Continue' → 'Start' 

 

When DaVinci opens, the Project Manager appears showing past projects. New users will see 

one blank 'Untitled Project'. Click New Project to begin. 

 

3. The DaVinci Resolve Interface 

The interface looks overwhelming at first, but each panel has a specific role. Use Workspace > 

Reset UI Layout to return to default at any time. 

Key Interface Areas 

Media Pool Left panel — holds all footage, audio, images for the project 

Left Preview Window Preview media from the Media Pool before adding to timeline 

Right Preview Window Preview the actual edit in progress 

Timeline Bottom panel — where editing happens; clips are placed and cut 
here 

Edit Tab Bottom navigation bar — switch here to access the editing 
workspace 

 

Panels can be shown/hidden by clicking their icons. Drag panel edges to resize. Removing 

unused panels (like the Media Pool after dragging footage to the timeline) frees up workspace.  

 

Improving Performance on Slower Machines 

• Go to Playback → Timeline Playback Resolution → Half or Quarter 

• This makes the preview blurry during editing but export quality is unaffected 

• Very useful when working with high-resolution footage (4K, 1080p) 

 

4. Basic Cutting & Editing Techniques 

Cutting is the most fundamental editing skill. It involves removing unwanted sections of footage 

to tighten the video and improve viewer retention. 

Adding Footage to the Timeline 

• Drag media files from a folder directly into the Media Pool 

• Hover over clips in the Media Pool to preview them 

• Click and drag from the Media Pool down into the Timeline to begin editing 
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Navigating the Timeline 

Playhead Red vertical line showing current position in the video 

Click ruler Jumps play head to that point in time 

Alt + Scroll Zoom in/out on the timeline quickly 

Spacebar Play/pause the video 

Arrow keys / W & E Move play head one frame at a time for precision 

+ / - buttons Zoom in or out on the timeline 

 

Making Cuts 

• Razor Tool: Click the blade icon in the toolbar, then click on the clip to split it  

• Keyboard Shortcut S: Instantly splits the clip at the current play head position 

• To delete a clip: right-click → Delete Selected, or press D / Backspace 

• To close the gap: click the empty space and press Delete/D to auto-join clips 

• Drag clip edges (Arrow Tool): Hover near the edge until a resize icon appears, then drag 

to trim 

 

Adding Transitions 

• Fade handles: Hover over the top corner of a clip and drag the white handle inward 

• Effects Library: Click the Effects tab → Toolbox → Video Transitions → drag onto a cut  

• Common transitions: Blur Dissolve (subtle), Cross Iris (showy/demo), Cross Dissolve 

(clean) 

• Resize transitions by hovering over their edge and dragging 

• Audio transitions: Effects → Audio Transitions → Crossfade (smooths harsh audio cuts)  

 

Always save your project: File → Save Project. DaVinci will remember your project in the 

Project Manager when you reopen it. 

 

5. Syncing, Linking & Keyboard Shortcuts 

Understanding how audio and video tracks relate — and how to work with them independently 

— is essential for professional edits. 

Linking & Unlinking Clips 

• By default, audio and video are linked — they move together 

• To unlink: select clips → right-click → Link Clips (uncheck) 

• Alt/Option + click: Selects only the video OR audio track, not both — a quick alternative 

to unlinking 
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• To relink: select all clips → right-click → Link Clips (re-enable) 

 

Why Unlink? — Audio-Only Cuts 

When cutting silence from audio without creating a jarring visual jump cut: unlink the tracks, cut 
only the audio, delete the silence, and rejoin. The video continues playing smoothly while the 

audio skips the pause. 

 

Essential Keyboard Shortcuts 

Alt + Scroll Zoom in/out on timeline 

Spacebar Play / Pause 

S Split clip at play head 

D / Backspace / Delete Delete selected clip 

D on empty space Close gap between clips 

Arrow keys (W/E 
customizable) 

Move play head one frame at a time 

Alt + click on clip Select only video or audio track 

Ctrl + Z Undo last action 

I / O Set In/Out points for export range 

 

6. Keyframe Animation 

Keyframes allow properties like position, zoom, and rotation to change over time — creating 

smooth, automated animations without manually drawing every frame. 

How Keyframes Work 

Think of a magic flip book: set the starting state on frame 1 and the ending state on the final 

frame — DaVinci automatically fills in all the frames in between. This is called interpolation.  

 

Creating a Basic Animation 

• Click the clip → open the Inspector panel (top-right) 

• Navigate to the Transform section (Position, Zoom, Rotation, etc.) 

• Move the play head to the start position → click the diamond icon next to 'Position' to 

enable keyframes 

• Move the play head to the end position → adjust Position/Zoom/Rotation 

• DaVinci automatically creates keyframes and animates the transition 
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Controlling Animation Speed 

Faster animation Move the end keyframe closer to the start keyframe 

Slower animation Move the end keyframe further from the start keyframe 

Hold keyframe Add a duplicate keyframe to lock the value before changing it  

Visualize keyframes Click the keyframe graph icon to see keyframe positions as dots 

 

Common Animation Types 

• Position: Move objects across the screen (left to right, pan effect) 

• Zoom: Scale up (punch-in) or scale down footage 

• Rotation Angle: Spin objects or logos 

• Pitch / Yaw: Tilt and warp in different axes 

• Stacking: Multiple properties animated simultaneously (e.g., zoom + position + rotation) 

 

IMPORTANT: If you want footage to stay in a position before zooming out, always add a 'hold' 

keyframe at the same value before adding the final different keyframe. Without this, DaVinci will 

start the transition immediately. 

 

7. Overlays, Text & Visual Effects 

Adding overlays — text, arrows, PNG images, and animated graphics — directly onto footage 

guides the viewer's eye and communicates key information. 

Adding New Tracks 

• Right-click in the track area of the Timeline → Add Track 

• Higher tracks appear on top of lower tracks (like stacking Lego bricks) 

• Drag media onto the new track to overlay it above the base footage 

 

Adding PNG Overlays (e.g., Arrows, Icons) 

• Search Google Images for 'red arrow transparent', filter by Transparent color 

• Save the image and drag it into the new video track in DaVinci 

• Use the Transform handles to resize and position the overlay 

• Use keyframes to animate the overlay's position or rotation over time 

 

Adding Text 

• Effects → Titles → drag 'Text+' onto a new track 

• Double-click the text clip to open the text editor; type your content 
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• Use the Inspector → Shading tab to add outlines (strokes) around text  

 

Making Overlays Stand Out 

Drop Shadow Effects → Filters → search 'shadow' → drag onto clip; adjust 

strength/angle/blur in Inspector 

Stroke (Outline) Inspector → Shading → enable stroke → set color to black, 
increase thickness 

Reduce Opacity Inspector → Video → Composite → drag Opacity down to 
darken background 

Gaussian Blur Effects → Filters → Gaussian Blur → drag onto background clip 

 

Camera Shake Effect 

• Effects → Filters → search 'Camera Shake' → drag onto text or clip 

• Adjust Speed (shake frequency), Motion Scale (intensity), and Motion Blur in the 

Inspector 

• Great for exaggerating screaming, explosions, or comedic moments 

 

Adjustment Layers & Compound Clips 

• Adjustment Layer: Effects → Generators → Adjustment Clip → drag above footage; 

effects applied to it affect ALL clips below 

• Compound Clip: Select multiple clips → right-click → New Compound Clip; treat as one 

unit for keyframing or transitions 

 

8. Green Screen (Chroma Keying) 

Green screen (chroma keying) removes a specific background color so another video or image 

can show through — creating the classic cutout effect common in YouTube and gaming content.  

Step-by-Step Green Screen Process in DaVinci 

• Place your green screen clip on a track above your background footage 

• Click the green screen clip to select it 

• Navigate to the Fusion tab at the bottom of DaVinci Resolve 

• Click on the Median node, then press Shift + Space to open the tool search 

• Type 'key', select 'Delta Keyer', and click Add 

• Use the eyedropper tool — click and drag across the green area 

• Return to the Edit page; the green background should now be transparent 

• Use the Gain slider to remove any remaining green halo/outline 

• Reposition the subject on screen using the Transform handles 
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Free green screen footage is available on YouTube and websites with thousands of free green 

screen clips. Simply search for the subject followed by 'green screen'.  

 

9. Audio Editing 

Audio quality is arguably more important than video quality. Even great footage is undermined 

by poor, unbalanced, or unclear audio. 

Basic Volume Editing 

• Click a clip and hover over the white horizontal line to see volume handles — drag 

up/down to increase/decrease volume 

• Use the Mixer panel (Fair light tab) to see real-time dB meters for each track 

• Keep audio below -3 dB peak; avoid going into the red (causes clipping/crackling) 

• Use the track volume fader in the Mixer to adjust overall volume of an entire audio track 

 

Audio Keyframes 

• Alt + Click on the audio clip's white volume line to add a keyframe dot 

• Add multiple keyframes and drag them up/down to create gradual volume ramps 

• Perfect for fixing sections where speaking volume drops or increases unintentionally  

• Normalize audio: Select clips → right-click → Normalize Audio Levels → choose target 

dB 

 

EQ (Equalization) in Fair light 

EQ adjusts frequency bands to clean up audio and make voices sound crisper and cleaner:  

Band 1 (Low cut) Cut low-end 'mud' — rumble and background noise 

Band 5 (Bell curve) Boost mid frequencies to add presence and clarity to voice 

Band 6 (High shelf) Slightly roll off harsh high-frequency sibilance ('s' sounds) 

 

Save your EQ as a preset: click the + button in the EQ panel → Add Preset → name it. Apply it 

to future projects with one click. 

 

Adding Music & Sound Effects 

• YouTube Audio Library (free): YouTube Studio → Audio Library → preview and 

download tracks 

• Add music to a dedicated Mono audio track (separate from voice/SFX tracks) 

• Keep music volume low (well below voice level) and watch the dB meter 
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• Match music tone to video emotion: epic music for action, suspense for mystery, etc.  

• Sound effect types: Exaggeration/Foley (whoosh, impact, camera click), Meme/jingle 

clips, Atmospheric ambience 

• Use different tracks for music and sound effects for easier management 

 

Audio Transitions & Effects 

• Fade in/out: Drag the handle at the start/end of an audio clip 

• Crossfade: Effects → Audio Transitions → Crossfade → drag onto a cut  

• Echo effect: Effects → Audio Effects → Echo → choose a preset (e.g., Large Hall) 

• Echo is popular for comedic/sarcastic moments in gaming and commentary videos 

 

10. Exporting / Rendering 

Once editing is complete, the video must be rendered (exported) into a single shareable file. In 

DaVinci Resolve, this is done from the Deliver tab. 

Export Settings 

Tab Deliver (bottom navigation) 

Export name Enter your video title 

Location Choose your export destination folder 

Format MP4 (recommended over QuickTime for YouTube) 

Codec H.264 

Resolution Timeline Resolution (automatically matched to your footage) 

Frame Rate Timeline Frame Rate (set automatically) 

Quality Automatic → Best (reduce to High/Medium for smaller file sizes) 

 

Export Process 

• Set In/Out points: Press I to set start, O to set end (or drag the range bar) 

• Click Add to Render Queue — add multiple jobs if exporting several clips 

• Click Render All to begin exporting 

• Wait for rendering to complete — the MP4 file will appear in your chosen folder 
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11. Live Editing Walkthrough — Principles 

The instructor demonstrates editing a real YouTube video live, revealing the thought process 

and decision-making behind professional edits. Key principles demonstrated: 

The Rough Cut 

• Watch through all footage first to understand what you have 

• Make basic cuts, remove obvious errors, trim silence and filler 

• Position any important B-roll or overlays at appropriate points 

• Don't perfect anything in the rough cut — just get the structure right 

 

Disguising Cuts 

• Use overlays/slides to hide visual jump cuts — position the overlay just before and after 

the cut 

• Use punch-ins (zoom in on footage) at cut points to smooth visual transitions 

• Add crossfades on audio tracks were cuts sound harsh 

• Align eye-line when punching in — ensure subject's eyes stay at consistent screen 

height 

 

Sound Design During Editing 

• Add contextual audio (e.g., audience clapping) to establish setting 

• Use sound effects to exaggerate reactions (crowd noise, laughter) 

• Use compound clips to apply a single fade-out to multiple layered audio clips 

• Use audio keyframes to manually balance volume differences within a single clip 

 

12. Common Editing Mistakes to Avoid 

Advice gathered from professional YouTube editors and content strategists:  

Frontloading Your Editing Effort 

Spend disproportionately more time editing the first 30 seconds. YouTube analytics show most 
viewer drop-off happens here. For a 5-minute video with 5 hours of edit time: spend 2.5 hours 

on the first minute and 2.5 hours on the remaining 4 minutes. 

 

Avoiding Overediting 

More editing does NOT equal a better video. Editing should supplement the content, not 

become the star. Only add effects if they genuinely add entertainment value or clarity.  
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J-Cuts & L-Cuts for Natural Flow 

 

Problem Tiny silence between talking head clips feels awkward and 

unnatural 

Jump Cut Clips back-to-back — works, but facial expressions may look 
odd 

L-Cut Audio from clip 1 continues slightly into clip 2 (L shape when 
viewed) 

J-Cut Audio from clip 2 starts slightly before its video — opposite of L-
cut 

How to Unlink audio/video, overlap audio tracks slightly, merge naturally  

 

Top Editing Mistakes 

• Leaving tiny silences between talking head cuts (sounds unnatural) 

• Using the same sound effect repeatedly — always use 3+ variations 

• Wrong music for the tone — music must match the emotional pacing 

• B-roll or graphics unrelated to what is being said (confuses viewers) 

• Text overlapping with title bar in Shorts / vertical video 

• Not directing the viewer's eye — always have one clear focal point on screen 

• Spoiling the video's result in the intro before building tension/interest  

 

13. AI-Powered Editing with Opus Clip 

Opus Clip is an AI platform that automatically repurposes long-form videos into short-form clips 

for YouTube Shorts, TikTok, and Instagram Reels. 

Key Features 

• AI scans video content (not just transcripts) to find the best moments 

• Automatically reframes the video to vertical (9:16) format 

• Tracks faces and switches between speakers automatically 

• Adds animated captions synced to speech 

• Can add relevant B-roll based on caption content 

• Supports direct publishing to YouTube, TikTok, Instagram from the platform 

• Upload limit: up to 10 hours of footage per video 
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Workflow 

 

Step 1 Upload video file or paste YouTube URL 

Step 2 Select language, clip length (Auto, short, medium, 5–10 min), 
and video type 

Step 3 Choose or create a caption template (font, style, position, 

animation) 

Step 4 Select caption layout preferences (Fill, Fit, Split, 3-up, 4-up) 

Step 5 Click 'Get Clips with One Click' 

Step 6 Review generated clips, like the best ones, edit timing/captions if 
needed 

Step 7 Download clips or schedule directly to social platforms 

 

Manual Clip Editing in Opus 

• Edit Clip: Open clip editor, click on transcript words to set new start/end points 

• Remove specific caption words without removing the audio using 'Remove Captions'  

• Add text overlays/headings with custom fonts, colors, and background 

• Split and trim within the Opus editor without going back to DaVinci  

 

Opus Clip is estimated to be 3–4× faster than manually cutting and captioning clips. The AI finds 

good moments, but always review — not every generated clip will be high quality. 

 

 


